4.0 Bugs Megathread

Please post all the bugs you found (after installing 4.0) in this thread. I’ll keep this post up to date, so you can see which bugs got already reported. Reported already:

  • Crash on start on a Win 10 device. (if you have the same issue, please comment the post with your device, the OS Version, your graphics card and your player name). Please check if all your drivers are up to date.  
  • Disconnect after tapping the “i” button in the chamber of fortune AFTER opening all chests.
  • Friend Chat not working for some players
  • Sometimes no video offers (can happen depending on the Video Providers, so please be patient)
  • Some Android devices have problems with screens being unresponsive
  • Some players can enter the pro league
  • Lost Ninjas -> Will be fixed with a server update soon
  • No workers displayed when upgrading Trioxin Tower
  • Sometimes wrong info about players on tile
  • Settings do not get saved on Facebook

 

 

IGN: AJ 420

Device:amd anthlon

OS=windows 10 pro x64

i’m a windows user and after updating my game

when i get connected… its keep crashing

i cant even get online to see the glorious update

i would rather want my previous version of rr2 atleast i could get online and enjoy normal rr2

#cursed4.0

Hey, it would be nice if you could add your device, your OS version and your player name in the post.

just edited my post

I got the Update on my Lumia 650 Windows 10 (Version: 1709, Built: 10.0.15254.490) unfortunately there are still no Videos available for boost or free chests… 

Connection issues on Windows 8, not frequent but occasionally.

Pro league buggy, now says marksman Cup and allows you to participate in it (haven’t done so but a member of the ally has).

Is he able to play? lol

Has scored 1,340 apparently, that’s what it shows on the alliance scores page.

Hey, could you give us the player name of your alliance member who is able to participate please?

Using Xiaomi Mi Max 2 (Android), buttons are now not very responsive. During raids, sometimes I have to press the buttons on the touch screen many times before it gets any response.

Still no videos on Windows 10 (lenovo G510 laptop)…

https://www.youtube.com/watch?v=k3z5vOrLXpc

http://en.miui.com/thread-646197-1-1.html

It seems like this isn’t a problem with the latest Royal Revolt Update. It’s most likely a problem with an update you had on your device in the past.  

 

Anybody is able to participate, the participate icon is blue. 

Lenovo and Windows 10 tend to have problems with ads. I had a Lenovo Windows 10 laptop and I could get ads only 50% of the time, of course, I would always get the reward for it, but it was sometimes frustrating

 

I don’t know… I have notice the same in Xiaomi mi a1 with android Oreo 8.1

In mi case I think it’s like it can’t recognized all the movements/touchs on the screen at the same time, for example if I’m moving the hero in a direction while I’m summoning troops and I tried to use and spell It does not work properly, but at the moment I stop one of the two other actions it works. I have never noticed that before yesterday and I have had no android updates in a few weeks.

I wrote a very similar topic few days ago.

 

Yes, this is exactly what I’m facing too, and it’s only happening to Royal revolt 2, after the update. Prior to the update everything was fine.

i cant enter in game after the upgade  … I use computer PENTIUM ® DUAL CORE  … S.O. windows 10 … My account of rr2 are :

_TITANIA_

Vallen.

Sir kullia 

You shouldn’t have more than one account, otherwise you will be banned