Advertisment Option Greyed Out: Unable to watch ads

HI… I am facing problems with advertisements… I am unable to view ads in my mobile device to speed up upgrades and receive free legendary chests… It’s been over 12 hours since this problen was noticed by me, or so I think… I can easily watch ads on laptop, but I dont get the option on mobile… It’s greyed out… I tried reinstalling and yet this problem persists…

IGN: GrimScythe2001
RR2 version: 5.0.1
Mobile Device: Galaxy M20
Mobile Software: Android v. 8.1.0 (oreo)

First Notice of this problem: since last server maintainence

Ads helped me a lot in strengthening my defense by providing good lot of gold… I hope this problem is fixed soon…

Edit: I get ads right away at the first attempt in laptop, but I dont get ads for several times in mobiles. I am sure the region is same in both laptop and mobile. Why is there difference in laptop and mobile regarding ads?

Thank You…

Hi there,
From our side we have not changed anything regarding the ad system.
This looks like something happening on the ad providers side.
I am sorry, but we cannot reproduce this issue.

1 Like

Did you disable GPS? Try to enable it!

Thank You so much… It’s not a problem anymore… It fixed automatically… I face a lot of problem with ads… In one laptop, ads can easily be viewed… In other laptop, ads are not at all available… In mobile, I get ads after 10-15 tries… It a complex process to get ads… haha… Anyway, thank you again… :rr2ninja::rr2ninja::rr2ninja:

1 Like

Happy to hear that!

1 Like

This is happening in my account, can’t do boosts for taverns, farms, upgrades, free chest…nothing, no ads now since the beginning of conquest. Tried the “vungle fix” but it hasn’t worked. Please fix. Also happening to others in my alliance as well.

Thanks :slight_smile:

Switch to another landscape and then Back. Works for me always. Cant say why.

I’ll give it a try. Thanks

Nope… doesn’t work… Maybe it works for some people… For me, sometimes going to the dungeons and again returning back works… Only Sometimes… Most of the time, it doesn’t work either… Getting ads is a very tough work… :sweat_smile::sweat_smile::sweat_smile:

Thanks, seems to have been fixed…at least for the moment…with the latest maintenance update. Fingers crossed it stays that way.