Ajax and Artemis powers not displaying correctly

Ajax’s last 2 powers are not showing any stats from the Shrine of Power and pressing the i button does nothing. 

Artemis’ powers show what seems the fully upgraded power when the upgrade button has been selected. 

Same bugs too, my charge should be level 11 now,but it showed level 2! FG please fix it!!

The same thing happens to me, as it looks:

And the real level of power:

Screenshot_20171217-171324.png Screenshot_20171217-171247.jpg

This causes the Configure button of all heroes to malfunction and lights up even when there are no new powers to equip.

Please fix it!

 

Have you tried writing to the tech support? I mean, with the uncertain status of the devs, this may be a better communication channel for now

Infamous, this forum is not to report these bugs?

Where should we report these bugs?

The actual place to report bugs would be tech support, which is located here https://forums.flaregames.com/forum/89-support-help/

With this said though, this forum is still a great place to receive help from the fellow players and/or CaptainMorgan and other devs. So, in most cases I advise doing both, as sometimes you may end up being sent to the tech guys and in some cases you may not. Generally, it always helps to check this forum for the cases like yours and work from there.

@JuaniusGuerrero we are currently looking further into this issue in the hope to fix it soon. 

It would be helpful if you could tell me whether you also have the same problem as this thread:

 

 

@CaptainMorgan, it happens to me exactly the same as they report in that forum, the only one that does not happen to me is Artemis. This started to happen to me just when I upgrade the ajax power with which I have the bug (Images previously attached).
This causes the Configure button of all heroes to always highlight as if there was a new power.

@CaptainMorgan, attached screenshots:

Screenshot_20180111-171645.jpg Screenshot_20180111-171717.jpg Screenshot_20180111-171703.jpg Screenshot_20180111-172851.jpg Screenshot_20180111-171729.jpg

 

This bug persists in this version of the game.

Even after last update, there’s still glitches/bugs in power’s display …

I just upgraded Ajax’s Whirlwind to max level. Before this, its stats were displaying correctly.
Now after the upgrade, this is what it shows (normal and after clicking on the Info button) - tried a relog but nothing changed

.jpg.09dd5d670cdb7c527070dc662ff87463.jpg)

And this now - Whirlwind maxed doesn’t show stats. Devouring strenght was showing them, after last upgrade does not any longer. Shield slam maxed long ago still shows stats.

Seems every time I upgrade an evo, stats go play hide and seek.

 

Well I am also facing the same issue as others are doing just yesterday I started raising Ajax shield smash spell it should be at level 3 but it is showing level two in shrine but when I am checking it in Ajax setup setting it is showing level 3 shield smash as it should be. Also a strange sign is showing above my heroes spell which reads "new power is available"As mentioned by @JuaniusGuerrero in his post.

@CaptainMorgan please look into this I wanted to share my screenshots but I am unable to upload them here because max file is allowed at 1.95 mb and unfortunately my all screenshots are little bigger.

This is an ongoing bug for me.  Both Devour Strength and Shield slam show no information under the Shrine of Power list and the (i) button does nothing.

This on my Ipad Mini 2 running latest iOS. Not a big deal but still a bug

IMG_2404.jpg

IMG_2405.jpg

Same has happen to me, finished upgrading slam and now its back to lvl one with no stats. Also in my shine of power the lighting blot is flashing even tho ive started another research.

Hey guys, this is a known issue, and we’re looking into it but it’s been proving elusive to fix. We will release a fix as soon as we can, but as far as we can see there are no major negative side effects (other than it being annoying).

Hi @CaptainMorgan,yes appears to be only cosmetic. 

This will be fixed in the next version.