Android 5.0

It’s a conspiracy, to promote Android 5.0 and how to be, other users with lower versions? You lose market

Hello Synoptique, 

These requirements are made because the game requires mid-high end devices, the whole game requiring better performances to run smoothly. Devices on Android 4 might not have good enough specs to enjoy the game fully. 

Sorry for the inconvenience.