Battling players with different versions of game?

Quick question, really doesn’t deserve a whole post but I couldn’t find the answer searching so…

 

Can you battle other players if their version of the game is different? In either direction, like can someone with a newer version fight someone who hasn’t updated yet? Or vice versa? Or do both players need 100% the same version for either of them to challenge the other?

 

Thankyou

From what I have observed, new main version is able to attack the player with any old version, however old main version is not able to attack the player with new main version. For new sub version, as long as both of you are in same main version, no issue on battling. Below are some examples:

 

Player with version 1.6.0 is able to attack the player with version 1.5.0, 1.4.2, 1.4.1, 1.4.0 and below

Player with version 1.5.0 is not able to attack the player with version 1.6.0

Player with version 1.4.2 is not able to attack the player with version 1.5.0 & 1.6.0 but able to attack the player with version 1.4.1, 1.4.0 and below

Player with version 1.4.1 is able to attack the player with version 1.4.2, 1.4.0 and below

It use to be both players needed to be on the same version the attack and interact with each other. I am not 100% if that is still true. I do know that a old user say on 1.4.1 cannot attack a 1.5.0 user. I am not sure if a 1.5.0 can attack a .1.4.1 on this  current set up