Blacksmith boost button gone

From the beginning of the Blacksmith Event the Boost Button Outside is gone…
inside the Building this Button is working, please check
Android 8.1+ Windows 10


The boost button “outside” isn’t deactivated… it just isn’t there.

This button is now only available when checking the items forge overview (picture 2).

Flare changed this because if you look closer, there’s no space for a 6th button outside… :wink:

So they replaced the BS boost button, by the new RuneHammer button.

that is not solved well … but okay … we have to look into the sub menus … irritating

I agree on that but… blame the buttons for being too big, don’t blame me :stuck_out_tongue:

This upgrade button is not required at the maximum level

Well noticed Jesper!

Perhaps it would be cool if you created that as a new thread on the Ideas section?

maybe tomorrow … its late now :zzz:… i changed the topic to button is gone…

1 Like

That’s because of the new runes function, which can’t be boosted

So this change actually makes sense since you’re not really boosting the Blacksmith’s building but only one of the functions inside that building

I do not like the consistency of how boosts are started now.

It makes sense but…

It’s less convenient since now we have to make 2 clicks instead of just one :stuck_out_tongue:

Maybe i’m “Monk” – > best is all the same

One of the first things that came to my mind when I saw the 24h cooldown for rune production was to activate the Blacksmith’s boost to see if it would reduce the production time :thinking:

And when I saw that the button was no longer on the Blacksmith’s building, but only on the melting items feature I already knew the answer :laughing:

We had to move the button, because of space limitations. So we moved it inside the building.

Jepp that was our thought behind it.

2 Likes

Anyone else noticed that the melting speed changed?? My BS is max and the time changed.

Yes, you are right the time increased Neapels tothetzte double!

it has been reduced during the last server update.

Before it was boosted by a factor of 3, now it s only 2…so yeah…we are ‘loosing’ a third of what we had before…thanks Flare…(sigh)

https://forums.flaregames.com/t/live-server-update-08-08-2019/33940/2
Hi Cirvade, you can have a look here.

Since this is not related to this topic though and the topic was solved already, I am locking this.