Blizzard bug?

I was playing on the 25th ninja island (the boat before the dreadnought) and there was a lot of werewolves and Gargoyle Towers, so I decided to use my Blizzard Spell that had just finished upgrading. I go in to the round and everything is going as normal until I use Blizzard for the 2nd time in the battle. Everything stopped and I had to exit. I lost the attack and had to do it all over and this time I did it with Stun instead and it worked fine and there was no crash. Please look into this as I want to use Blizzard, it’s a very important spell (to me, at least)

I used Blizzard excessive in Ninja Event and had absolutley no Problems.

Same here.

You did upgrade your Windows version to creator release and play on PC? There you go… a freeze. When it happens, keep you fingers away from that mouse plus keyboard. It has nothing to do with blizzard, it just happens on Windows.

 

I haven’t updated my laptop since I’ve gotten it back, I think it automatically downloads them without my permission.

Plus, I think it’s more than a coincedence that everything is fine and then the ONE time I use Blizzard it doesn’t work.

P.S. I attacked a dungeon with Blizzard today and it worked fine, so the “bug” is no more

Thanks for the reply GalaMorgane 

You are welcome Awesomest. ?

So we finally have squeezed the information we needed. GalaMorgane is secretly Dena4 lol

There is no blizzard bug, it’s just RR2’s bug with 1709 windows version.

I have only had problems with bugs that concern Blizzard which is interesting. Fritz works only about 80% of the time and then the first time I use Blizzard since the new update (which is obviously the cause) it doesn’t work