Can't get any rewards after watching video advertisement

Hello, I can’t get any rewards after watching video advertisement since I updated game to 3.8.1, including bonus chests, time discount, boosts ect. In the old 3.8.0 ver it’s alright. now the video advertisement is useless, hope fix the bug ASAP, appreciate.

Device: ipad mini 2 with iOS 10.3

Location: Chinese

 

I’m having a similar problem @mimizero with Windows. I can access the videos, but they loop on repeat so there is no way to exit them and get back to the game. 

I end up having to exit the game and log back on. Chests usually show up for me, but only after exiting the game and logging back on. 

Try waiting a little or relogging. Depending on the ad it can take a while to take effect (esp. for looping ads).

i dont even get ads anymore  only the message no ads at this moment

ads stopped a few days ago tried everything  deleted vungle sdk reinstall app reset app

nothing works

+1

It looks like there’s a new video type that doesn’t send the “completed” signal back to the game (or game doesn’t know to pick it up).

All videos haven’t worked for me for 3 days, android Oreo, Pixel XL, Ireland.

Try BlueStacks.(https://www.bluestacks.com/)  Add the same google account.

Of course you are on your own on this and I do not take any responsibility if it goes south.

Assuming you run Windows you could set up a back Windows machine (real or virtualised) running the same account.

Thing is if deleting VUNGLESDK no longer works you need different ‘hardware’ to perswad the Ad-system to grant you additional video ads.

Note: Using a different NIC is not enough.

As always: you are on your own on this and I do not take any responsibility if it goes south.

Same issue with me. Complained to them about it since these new ads have started, with no Exit button, but no fix to date.

My workaround has been to click the Download button after the ad has finished at least once. This will minimize the game and open the Windows Store. I close the Window Store and click to go back to the game, and it registers as me successfully viewed the ad and give me my chest or shortened upgrade time.

It’s annoying, but it’s better than exiting the game and logging back in.

@docarchy Open Microsoft Edge before you start RR2.

on win 8.1 I have no offers. win 10 & android everything is working

Also on 8.1 there is no update. there is version 3.8.0

The provider seems to have fixed something, all the ads are now stuck in portrait mode, and there’s an extra black screen when exiting the video, but RR2 now picks up the finish and activates the boosts. <- I hit this on Android only

I also saw similar issue above for Windows, used same solution, went to download, then back to the game again.

What will that do?

 

Up til now it reduced video ads of he looping kind to be offered.

Hello everyone. Long time listener, first time caller…  I’ve been having the problem with the endless looping of the Gameloft ads, too.  They are the only ones doing it though.  Seems to be the only ones I get lately which is annoying…  I’m on Windows 10 too by the way and usually have Edge open at the same time too, but it doesn’t make a difference.

 

It’s 4 days since I update the game to 3.8.1, I’ve watched about 30~40 advertisements and did not get ANY rewards !!! Don’t you think it’s a BIG problem? I mean the game’s ads is a very important support for non-paying players, now its useless and make me angry, even worse than don’t gets ads.

Is there any way to back to 3.8.0 lol…

Have you deleted the VungleSDK folder first too?

I can only relay the experiences I have gotten using this approach to be sure. So it may not work for you. Just wish FG/Vungle came up with a permanent solution…

 

Had that problem too, but it disappeared… I no longer have that problem because… I HAVE NO ADDS!!! hahahahaha

 

what I really like to know is, if this is affecting a whole lot of players… why isn’t someone from flare answering this thread!!! shame!

I’m also facing this problem of videos, happens several times when receiving a free bau or to advance some construction, I watch the video and it does not change at all and after a few minutes back to normal it’s strange that

I have the same problem as @OVRSLO. I watch an ad but I had to log out and back in to get the boost or chest. However, every time I boosted my farms over this past week I wouldn’t get the boost for my previous “ad for boost” even after I logged back in. I had to watch an ad for the next farm to get the last boost, then the next farm for the 2nd boost and so on. Shouldn’t have to work that way, extremely frustrating. Sometimes it will even say, “No available ads at the moment. Try again later.” Because the bug messed up the ad watching for boosts…can’t handle having to do all this extra work just for a boost. Please fix this flaregames. @Nikko @flaretara @PaSte @GalaMorgane