Did Not Receive Items From Gold Chest

I opened a gold chest today that I received as a daily prize chest. It showed the items that I was to get, and I accepted them all. But when I went to look at them after getting all the items, I found that I had not been credited with them. I know this to be the case because I had recently finished a major forging operation which left each of my gods with strong items, but also a minimum of items. I had no blue and green items among all my gods, and only a couple of gold items that were not in use. One of the items that I got from the chest was a gold sword. But there was no gold sword and no blue items when I looked for them. I was also very careful to make sure that I did not sell the items. And to the best of my knowledge, there was no increase in the level of my gold after opening the chests. If this had been the first time that it happened I would not even say anything. But it happened about a month ago as well. Though that time it was a Titan chest - which really pissed me off because there were some good items that I thought I was getting, but didn’t. 

In reading the forums I did not come across others having this problem. So I’m wondering if it is just me.

One other problem that I’m having is with signing in. I have signed into the forums roughly a half dozen times in the last couple of days. And each time it would not accept my password. Each time I was sent an e-mail telling me to reset it. The sign in always works then when doing the reset. But the extra couple of steps is getting a bit annoying.

Thanks for any help you can give me. It sure would be nice to be credited with the gold and titan chest that I did not receive the items from.

 

For the glory of Olympus

Benedict Donald  

Hi there Benedict,

Sorry that you are experiencing troubles. Please let me guide you to the correct contact:

  • Regarding the issue with not receiving items - please contact our customer support. https://flaregames.zendesk.com/hc/en-us/requests/new
  • Regarding the issue with the forum - please contact the forum provider. You can do so by scrolling to the end of the page:

image.png

Thank you!

Regards,

Madlen