Download stops, can't play on PC

Hi, I’m trying to play on PC the same account that I use on mobile (windows phone). The thing is, whenever i try to do so the download freezes at 41,9 MB (image attached). I even tried linking the account to another email but the same problem persist, when the game restarts it starts downloading again (WTF, isn’t it already dowloaded supposedly?) and freezes exactly always at 41,9 MB. If I use a new microsoft account it works fine tho. But I don’t want to start all over again, I just want to use the same account on PC (my phone connection sucks what makes it frustrating to play). Please help!

Edit: I don’t know why, but it seems I’m not able to answer the post neither to start a new topic anymore, can’t find the buttons anywhere (??)

Edited to include that space isn’t the problem (~160 GB free space). Will download and try a VPN tho, thanks.

Edit2: As expected, no deal with VPN. Still freezes at 41.9 MB. Why would the ISP be the problem when I play the phone using the same network? Only difference is wifi vs cable. And why using a new account wouldn’t have a problem? This is weird.

@Awey a somewhat dumb thing to ask, but what is your status space-wise? Sometimes having not enough space is the root of all evil. What may also help is deleting the installed files and starting with a clean game download, assuming you haven’t done this already. Also, the use of VPN may be of use in some cases, as it may very well be your ISP that is an issue.

Nothing yet. I’ve tried using my account in another PC and the same problem happens, so I’m doubting it’s a system problem.

@CaptainMorgan, looks like a question for you.

Tech support bro.

@Awey Hey Awey, did you find a solution yet? Because I have the same problem on pc, only mine stops at around 15 or 22 mb.

Hey @Nemetor and @Awey

Bro after reading this post I too downloaded Olympus rising on my windows Notebook again and everything is working fine and I did not faced any problem.May I ask what version of Windows 10 you guys are using and OS build.If possible try to upgrade your operating system and then completely uninstall the game  and then download it again from the windows store.

I tried this method with the latest Olympus rising version 3.9.5 and it is working fine on my system.

I hope this will help you guys.