Forge Bugs.......why?

 

I tried to forge a special titan object, but no improvement. I tried to forge anyway and I think it's a mistake, I only lost 10 million to get no improvement. could you explain why ?, is it a bug?

 

You still have the option to forge uniques but once you gotten the boost your next forges won’t improve the unique. 

 

yes, I understood that, but it is not correct that a player must pay this error. I think it should be fixed

The forge option will always be present - as you may/may not want to forge it with a silver/gold titan item.

This should be fixed though. If youve already forged for the level and you don’t have gold/silver items available, you shouldn’t even be able to select the forge option. 

Like really, there should be the old fashioned forge button, and a new refine button. Forge should be greyed out if your unique is upgraded for your level, refine should be greyed out if you don’t have eligible silver/gold items. 

in fact, this is what I would like to present. my object is at max, so if it's equipped it should not give me any options, instead it steals only gold coins in this way. I hope they resolve in some way.

@Madlen ,could you please pass this info to developers.

Hi guys,

if it shows no change, there will be no change. We appreciate your feedback though about how to make it more user-friendly, and we will consider it for a future version.

Thank you!

Yeah, we know that we are not gaining any increase in values but others have pointed out why not grey out forge options for unique items when it is already forged at max by player so as to avoid confusion.

As I said, it is a good suggestion and we will consider it for a future version :slight_smile:

thanks to you, I know very well that you work hard to solve problems. I simply wanted to highlight a situation that happened to some members of the alliance. so I created this post to give a starting point for reflection. thanks and good job

You are welcome!

@Madlen this issue should be fixed asap. After forging a unique and matching it with the current level, it still shows the forge option instead of refine.