Game is too laggy - please add the option to switch off shadow

I’m using a Xiaomi Mi Max 2 with 4 gb Ram and it can’t take the recent animations anymore.

 

Please add the option, like many other games, to switch off “shadow” so that the game can run smoothly.

I have a Xiaomi A2 Lite with also 4GB RAM and it runs perferct. 

Do you fight with bases that are filled with conquest and war boosted gargoyle towers + boosted necromancers?

Yes. Mine also. 

Try it, my IGN is o r k o (with spaces). Beware of Pheobe. 

Having that option would be great. 

But your mobile should not be having this issue. There’s probably something else going on. It might be an overheating issue perhaps. 

I noticed that the game gets laggy the more units I spam on my smartphone.

This didn’t happen this much before 4.0.

Playing on a BQ Aquaris M5 smartphone here.

PS: Please don’t switch me off @LacunaC  :slightly_frowning_face:

hahahaha *click*

 

I realize there’s so much details in the shadow of units. I’m sure switching “you” off will improve gameplay dramatically.

Damn you! ahahaha

Ok now seriously:

I’m all ok with lowering the graphics on the smartphone, if it will improve the game playability.