get free chest not working

still needs to be corrected…still not working ?

 

2 days later, GET FREE CHEST still not working!

Found this fix somewhere here. You might try to fix this by:

  1. exit the game.

  2. go to:

%LocalAppData%\Packages\flaregamesGmbH.RoyalRevolt2_g0q0z3kw54rap\LocalState

      (Copy the above and paste it in “Search”)

and rename the VungleSDK folder:   VungleSDK-bad.

  1. wait 10 to 30 minutes, reboot, and restart the game.

The above worked for me with Windows 10.

 

 

Hi Duarte (and IrishLady),

Sorry to hear that you have troubles with getting free chests.

I am glad though Duarte you found a solution to the issue for yourself.  It is delicate to reproduce ad issues, we, however, have not changed anything with the ads since our last announcement (which restricts the daily ads to 30). 

That’s why in general, we need very detailed logs and information to try to reproduce the ad issues, and even then because the ad availibility is dependent on the region it is not always possible to reproduce ad issues.

Thank you for your understanding.

That fix isn’t working for everyone…it hasn’t worked for me as the localstate file is completely empty (I have no vungleskd file to rename), and it isn’t working for other members of my alliance either.

 

Since Friday, my fourth day, the video does not work on my PC, Windows 10, please correct it.

Duarte gave you the answer. 

You can also try the following. Close the game first.

Open a cmd prompt with elevated permissions (administrator) . To do this click Windows symbol, lower left and type cmd. You see command prompt. right click this and use Run as administrator. Type WSRESET. Wait till this is completed (Microsoft store should popup).

Then do delete Vungle folder like described here. https://royal-revolt-2.fandom.com/wiki/Production_Boost

Keep that windows folder open, start the game. You should see a new VungleSDK folder appear. Give it a few minutes to reload new videos. Then try again to boost something or get a video chest. 

 

Thank you very much! But I tried several times, the video does not work.

It can also be a decimal separator problem.

I made sure decimal symbol is dot (.) , digit grouping symbol a comma. If I am correct a JSON command is send, including OS version. A few years ago this lead to no videos, since the string send for OS version was incorrect due to this. 

Thank you very much, but I tried everything, and the video still does not work.