how to access options and how to play with a game controller?

hello there!

I’m a total newbie to Royal Revolt and I just purchased an Xbox One controller for my PC.

I play Royal Revolt on a Windows 10 PC. 

First I want to know how can I access the game options? The escape and Tab key do nothing.

Then I want to know if it is possible to play this game with an Xbox One controller for PC? I try to use the controller during play but nothing happens. 

Perhaps if I can find the game options I can tell it I prefer the controlelr over the keyboard… ?

Thanks

Gz

Good Question, but I don’t think this game supports the use of a controller though.

I’m sorry to tell you this, but you can’t use a controller for the PC.

You cannot use any controller for the PC because Flare have decided not support any controller. Seem to be too much complicated to implement in the game

@grendizer

You can go to options menu by clicking this button: optionsbutton.JPG

However, unfortunately you can’t play this game with any controller. You can only use mouse and keyboard atm (beside touch screen function). On keyboard you can press button number 1, 2, and 3 for troops; button number 5, 6, and 7 for spells; button E for insta-troops; button Q for scream; button number 9 and 0 for scrolls.

That sucks. The only thing then that might work is a Wacom tablet then.

Thanks all for your help!!

@RoyaleDing2 : I cannot find this option icon you show. Do I have to press a keyboard key to make it appear?

So I understand this game isn’t designed for the Xbox controller, but is it possible to make this game beleive that the game controller is a keyboard? Like I would map keyboard keys on the controller buttons? Could the following app allow me to do that? : https://www.microsoft.com/en-us/store/p/xbox-accessories/9nblggh30xj3?SilentAuth=1&wa=wsignin1.0 

Thanks.

Grendizer

No, you don’t have to press any keyboard. The icon is on the left side screen:

 

Never tried it before, perhaps you can try it and give a feedback on “Is it works” here? so Desktop user can follow your step if they want play this game with controllers if that’s really works.

Hello @RoyaleDing2, this left side you’re showing is nowhere to be found on my sceen. I attach a photo of my monitor. (there is no print screen key on my keyboard).

Yes for the keyboard mapping on the controller I’ll see what can be done

@grendizer That’s the screenshoot when you attacking someone. You can find it when you go to your castle view.

 

EDIT: I just noticed that screenshoot is from beginning of the game, as Mag said below, you can access options button when you completed all the tutorial. The tutorial ended after you naming your king/hero.

Screenshoot:

Spoiler

 

Finish the tutorial and you will have all options :slight_smile:

OK thanks guys . told you I was a full noob  :stuck_out_tongue:

So I finally found the options button :slight_smile:

I’m testing some app that could help me use the Xbox One Controller. But to complete my test I need to know where is Royal Revolt 2 installed in Windows? I checked into program files and program files [x86] and I didn’t find such folder… Help!!

You can found it in this path: “C:\Program Files\WindowsApps”

I need to copy files into the app’s folder but I can’t get full access to the WindowsApps folder, I tried many things. Giving up! :slightly_frowning_face:

You can search how to get full permission access to certain folder in windows from Google: https://winaero.com/blog/how-to-take-ownership-and-get-full-access-to-files-and-folders-in-windows-10/

But if you’re already giving up then that’s the end. Just enjoy the game with current control gameplay facility with mouse+keyboard like most of us, RR2 Windows 10 users. ?

I got it working! Previously I was trying to use TOCAEDIT XBOX 360 CONTROLLER EMULATOR APPLICATION but it wasn’t easy. Now I got it working with Xpadder ! http://xpadder.com/ 

:stuck_out_tongue:

I don’t know much about this game because I’m a beginner but years ago I’ve been using a software for USB controllers which emulated keyboard.

Basically you could link every controller command to keyboard.

Didn’t work perfectly on analogics (movements of char) and it was “illegal” for most of games because it was detected as “cheat”.