my game just won't start...

Hello,

sorry I don’t know how to make introductions so i’ll straight to the problem.

I use a PC running Windows 10, and I downloaded Olympus Rising from the store (version is 3.6.1.0).

the game just gets stuck at the name showing and stay that way till it closes on itself.

what should I do?

sincerely.

Hi MJDCOOOOL,

Please try this procedure:

https://flaregames.zendesk.com/hc/en-us/articles/214117945-Stuck-Game-Updates-on-Windows-PC-2016-11-25-

I have my Windows set up to receive the time automatically from Microsoft servers, and the game doesn’t even lead to the download update page…

here’s a screenshot showing where it’s stuck…

I have tried erasing the data, redownloaded and reinstalled the game, but nothing worked…

@MJDCOOOOL Sorry for the problems you’re having, we will be releasing a new version today, it would be great to know if you still have this problem with version 3.6.3.

I installed the update and the same issue occurred, same screen as before, it works fine on my Android tablet…

any other advices you can provide me?

thank you.

@MJDCOOOOL, could you please follow these instructions and send a private message to me with your dxdiag file attached? We will then see if we can find out why it’s not working for you.

https://wizards.custhelp.com/app/answers/detail/a_id/1271

Btw, not same issue but possibly related, if I start the game and then resize the game window (e.g. switch fullscreen to non-fullscreen mode) on that initial screen, the game gets stuck until it eventually closes.

Resizing the game on the next screen (background with various heroes, troops and creatures) after the “loading” or “connecting” text appears, on the other hand, works without any issues.

 

In case the original issue mentioned in the posts above still is unfixed, this related issue possibly might help find a cause? Dunno, but can’t hurt posting I guess.

confirming all of this. 

Thanks. I have observed this issue, but we’ve not discovered the source yet. We will work on fixing it soon.