Not depends on you but....

In my device videos for legendary chest,upgrade time and so on, have not worked for more than two months. You answered that you’re working on the issue and you’ll solve it as soon as possible. That’s not depends on you cause i guess the main guilty is the provider which give you the videos. Here i’m talking about that an important service of this game has not worked for several months. Not days,not weeks but months. And i’m sure that me and many others can’t take advantage of it. That’s bad. Especially after the latest update which gave us more levels. It would be cool to decrease the upgrade time through those videos but that’s not possible. How much long will still be this situation? Keep in mind that many players like me are affected by this problem. And those who have few workers are the most damaged. Reduce the upgrade time of a 10 day upgrade time tower would be really nice,especially right now…

Videos on my Android phone stoped working some days ago and I have no idea why…

I haven’t encountered any issues on Android?

Videos on windows and Android are working for me so definitely not everyone face same issue.

Get ready for + 2-3 extra tower levels as these levels will be over for many after the event.

 

I have wp and i had got the same problem, i tried to reinstall RR2 and now i can see all videos.

Hope it helps.

Regards! :grinning:  

It seems videos don’t work all the time for all the countries, mine are working again :slight_smile:  

My videos were working until today afternoon. Now it stopped  :open_mouth:

My dev is a huawei p8 lite (Android) and videos have not worked for more than two months. 

The good thing is: with Android your RR2 account is your Google account.
Which means you can’t lose it like Windows or iOS players. Some players
reported, that they uninstalled RR2 (and probably with that also the ad providers
part of the app) and reinstalled and after that got ads again. Probably after
some waiting time, like it is for me in Bluestacks (Android): With a new RR2
version the ads are not clickable for some time (supposedly while the ad
software is loading).

You may give it a try, the reinstalling and/or Bluestacks, if you have a PC/laptop.