Not receiving ad-for-free-bonuses anymore

Why am I no longer being offered the ads in exchange for a free bonus anymore?

I’m current on updates.

I’ve waited until the next day before trying again. I’ve tried buying bonuses to see if it would maybe reset. But no luck.

I’m going to give this one more day to correct itself and then I’m going to move on to playing another game and forget about this one.

FWIW - I had been receiving free bonuses for at least a week after I updated so…

UPDATE: The fix suggested below did eventually work, but on my Windows 10 computer, the indicated folders were hidden and I had to give myself permission to access them before being able to eventually rename the correct folder.  There were several folders with the  VungleSDK name.  Eventually, I found and renamed the correct folder.

Thank you.

This happens with a lot of players after updates

You need to rename the following folder:

_C:\Users\Username\AppData\Local\Packages\flaregamesGmbH.RoyalRevolt2_g0q0z3kw54rap\LocalState\VungleSDK\ VungleSDK _

Rename it into whatever name you want. Open up the game again, you should be able to watch ADs now. Watch one fully, let it pay out, go back and delete the folder you’ve renamed; a new VungleSDK folder has already been automatically created.

Edit: as a side note, renaming the folder initially fixed the issue for me, however shortly after I stopped seeing ADs again, at which point I fiddled with it some more, this time renaming AND deleting it entirely. After a few tries it finally worked.

Works like a charm. Thanks ?

I am having the same problem. May I ask how did you find the hidden folder?

 

You have to enable the view of hidden folders. But you can also just copy the whole path and paste it in your Windows Explorer.

Nice that you guys found a fix for this, but any selfrespecting game maker should fix this ASAP because most players wont know this and are basically left with only half of the food, thus half of the battles to fight. Making them because of this bug 1/2 of a player compared to those who do get the option to run the adds…

In a perfect world this would be so true. And like you I too woud love to see fixes happening within a day.

However I have seen people near me struggling to get software to run smoothly on PC’s and I know it is near impossible to get it flawless. The variables of systems used is mind boggling if you take into account software, hardware and drivers used on today’s computers/phones and other devices.

I too at times get frustrated with bugs in games. Then I ‘need’ remind myself that a game is not a necessary part of my live unless I make it so.

Obviously this isn’t a perfect world and I understand what you say but really in game this is kind of a big thing. If they can’t fix this then they should take out the boosts for everyone to make it fair again.

Three days passed and I’m not getting AD offers again, this has never been this bad before. Flare pls.

What about windows 10 mobiles. I am not getting any video offer from about a week . Its irritating flare.

Like I mentioned in a different post the only workaround that does work is to use a Windows desktop  PC capable of running RR2 from the app-store. Sign in with the WMP 10 account and have it synced. You should at least be able to use this Windows desktop PC as a means to start the boosts, the build time cuts and get the free chests when needed.

If you then still have issues getting the advertisements going for your RR2 account on this Windows desktop PC the rename ‘vulgarsdk’ bit should get you on your way.

 

NOTE: be sure not to override your existing WMP 10 settings linked to the OneDrive when you initial sync on the Windows desktop PC or you will end up loosing the progress you made on the Wndows Phone with a clean king or queen. So use this workaround at your own risk only.

You sure what you wrote in the “note” works that way? Althought I don’t play this game on mobile, I have had OneDrive disabled for months now, with zero issues related to cloud saving.

Well, it works at least with an up-to-date/synced OneDrive linked account.

Frankly if you get the settings.dat file from the somewhat working account you always have a way back I guess (clueless as to how to get that file from an iOS device to be blunt). But for the Android version you have the option of Bluestacks or any other emulator and go the same way simple as the PlayStore need an account to start with and if you use the same account it should work.

I have the mentioned file now backed up just in case for the next time I need to do a clean installation of Windows 10 (Desktop). That way I can install Windows 10, install the RR2 app from the store. Rename/override the then “fresh” settings.dat file and take it from there.

Unfortunately I have yet to find an easy dummy-proof way to “see/browse” the Isolated Storage Enviroment of a Windows Mobile 10 phone. So any tips are welcome. I have an alliance member running the game on a WMP10 and when the advertisements stop once again on this WMP10 used for playing RR2 the mentioned workaround is an option to continue.

 

In the end it is not us who needs to give advice on this or come up with workarounds. Hence the note.

I do not foresee any FG developer jumping in here either though.

One last thing I wanted to bring up is that the issue is likely due to the introduction of the new type of ads, the endlessly-looping ones.

That is the single and only thing that’s changed about the AD system in the recent year, at least on the PC version. We now get ads (especially about that king of thieves game), where they play out, then immediatelly start being re-played from the beginning, forever.

You have no way to wait for them to end, so you have to press the “X” button after that AD plays once, at which point game is having huge issues recognizing whether or not the AD has actually been fully played out, and applying the appropriate building time reduction or the free Golden Chest. You sometimes have to wait 10s for the game to recognize that the AD has been properly and fully played out for this player, and sometimes you just have to exit the game completely and restart.

I’ve no way of knowing if that is the culprit behind the issue, but I have already seen the new ADs in their non-looped versions, so if there is one thing Flare Games could do, it would be to remove the endlessly looping ADs completely and replace them with their 1-time-played versions.

@AzureKnight in the Bug & Problems forum I made an entry concerning the VungleSDK used (assuming I am correct in noticing the SDK used is version 1.3.16.0) and had a look inside one of the the subfolders of the folder which when removed would restore Ads being available again.

_C:\Users\Username\AppData\Local\Packages\flaregamesGmbH.RoyalRevolt2_g0q0z3kw54rap\LocalState\VungleSDK\ VungleSDK _

It seems the looping/buggy ones are made with Adobe Illustrator 19. Perhaps it’s these Ads making issues?

I stil think the endless, looping ADs are the issue. I’ve also noticed in the last 2 or 3 days that they seem to pop up less often for me.

But they’ve made another ■■■■■■ idea, and we now see a completely new type of ads, ones that loop forever and don’t have the “X” button to close them - instead, the only way to properly ‘end’ them is to click the ‘download’ button for whatever game they’re advertising, which opens up a new tab in your internet browser. Extremely intrusive and ■■■■■■, to be frank, not to mention someone might get pissed off by them so badly to actually go and download that other game that’s being advertised, which I’m sure is not in Flare’s interest at all.

Hmm yes ads for “King of Thieves - ZeptoLab UK Limited”, “March of Empires: War of Lords - Gameloft” come to mind. Highly annoying.

Ooh before I forget on WMP10 pushing the back button ‘<-’ will end the loop.

I am thinking they need to take into account the following: 

General notes

Please keep in mind for UWP builds: the Back  button is supported on mobiles, but not on PCs (keyboard). This can result in different behavior and user experience for UWP builds.

 

See: https://support.vungle.com/hc/en-us/articles/211339368-Get-Started-with-Vungle-Windows-SDK-v-1-0-v-1-3-16

Guess someone making the ads clearly is not taken the general notes into account when it comes to the Ads and Windows devices.

 

 

Now if version 5.1 were to be used the showing of the “Close” button is described in: https://support.vungle.com/hc/en-us/articles/115000506192-Get-Started-with-Vungle-Windows-SDK-v-5-1-

Showing the Close Button

To control whether a user has the option to close out of an ad, use the forced view options in your app’s advanced settings on the Vungle Dashboard.

SMH

Well, I’ve been renaming VungleSDK folders, I’ve been deleting them, I’ve been restarting my PC, I’ve tried buying bonuses, I’ve tried fighting battles in between attempts, I’ve tried starting/ending construction between attempts, and I’ve tried putting on my lucky shirt but still nothing works.

I still cannot get the free bonus for ads to work anymore.

Maybe I just need to give up and move on.