Please help with this bug ASAP!:( quite urgent!

Ok so yesterday when I tried to build a skull tower for the first time (with a spare tower slot, enough gold, enough workers etc) the game dims and ‘connection lost’ shows up, then re-connecting and when it’s connected again, back into the game, the tower is not in the building process. So I tried to build again (I.e. clicking on the build button with amount of gold required) then the same happens bringing me out of the game and so on. After many tries and trying to build the tower in different spots it still doesn’t work so I deleted the game, re-downloaded, re-downloaded my game data, still, wouldn’t let me build a skull tower! :slightly_frowning_face:

please resolve this ASAP team Flare :slight_smile:  cheers

IGN: GiacobbeYan

 

Above: when it dims then quits the game, next will be reconnecting… (again, the tower is not built! Even though it looks like it is, before taking me out of the game)

Weird bug. Probably it’s time for you to buy a new phone, seems your current phone couldn’t handle this game anymore, too many new pets/beasts perhaps

can he blink so?

Hello, @GiacobbeYan! Please submit a request to our support team so we can take a better look at the issue and help you with it: https://fgurl.net/help_me