[Solved] Can't download games only from store Windows 10 PC

#1

I just reinstall my windows, but when I want to install games, I can’t even go to their page. No matter how much I clicked the icon, it won’t go anywhere.

I can install the apps without problem though.

Anybody knows what’s the problems?

ps. Already did wsreset, search troubleshoot @control panel

#2

Stop Windows Update service and remove/rename C:\Windows\SoftwareDistribution just to be sure.

Restart/reboot after and try again.

Also try to check if your store-account is correctly sync’ed.

Cleanup temp files might do the trick.

#3

I stopped Windows Update, can’t remove/rename “SoftwareDistribution” folder

After rebooting, it’s still same.

My Microsoft account is correctly synced

Do you mean cleanup temp on C:\Windows\Temp?

It’s so strange, because I can go to apps, music, and movies download page but not for games. Only games… :slightly_frowning_face: All games

#4

Start an administrative commandline.

Type: Net stop wuauserv

Try to rename/remove the folder mentioned.

Afterwards restart de service with ‘net start wuauserv’ or reboot.

#5

Tried it but still same, not works.

#6

Update: I can download and install the game through my library (list of my previous game). I still can’t go to each game download page.

#7

Not sure if it will help much but can you provide screenshots?

(Frankly I am a little lost as of what you mean with ‘I still can’t go to each game download page’.)

Also I will assume you already submitted a support ticket with FG.

#8

My Windows Store:

Spoiler

 

If we choose one of them, we can go to their download page. I can go to apps download page, but not with games, no matter how much I clicked on the icon, it’s download page won’t appear.

Line apps download page:

Spoiler

 

Finally I can only download from My Library and that’s mean I can’t download the other games that I haven’t download in the past.

Spoiler

 

No I haven’t because it’s more my OS fault not them and this problem affect all the games in my Windows Store.

 

ps. For now I can play RR2.

ps2. I still looking for solution on the websites unfortunately until now haven’t found any that works for me. I even reinstall again my windows but no change, the condition of my windows store still same.

#9

https://social.technet.microsoft.com/Forums/windows/en-US/91643dd2-308f-47da-be79-e693707d8b97/not-all-apps-showing-in-store?forum=w8itproinstall

Give the solution mentioned a go. Try to  see if you get more apps visible. I would try region USA for a start. With different region settings you to see different apps available.

If more apps  became visible you need to figure out which regional settings you had before your re-instalment of Windows. Especially if you made purchases in different regions you may have to switch back and forth to get all your apps back.

#10

I can search all the games from Windows store, but when I clicked the icon button, their download game page won’t appear. So I think it’s not about “not all apps showing in store” problem.

I downloaded RR2 through My Library by clicking this arrow button (without go to their download page) : Capture.JPG

ps. My previous and current regional setting are same, there’s no change when Installing Windows.

ps2. Perhaps it’s because my windows is old? My Windows .iso was from 2015. But then, I have no problem with windows store before reinstalling my Windows, only minor problem about free video ads in RR2 (This is one of some reason I reinstalling my windows. Unfortunately, after I reinstalling windows the ads problem is still there.).

#11

Updating windows 10 to the most current version is in my view ‘beter’ then leaving it in a more unsecure state.

Same goes for Apps. Windows 10 (1709) Creator Fall Update is the most current unless you have the Windows 10 Preview version (I can look that one up) but sticking with the regular is preferred.

Far as I can tell you could just download the latest Windows 10-ISO directly from Microsoft. Assuming you have/had registered Windows 10 in the past the latest ISO should be useable for installing the  PC from scratch with thereby forgoing a lot of updating of the OS itself.

Unfortunately I am out of ideas at this time as to how to resolve your issue. Hope someone less will chime in with suggestions. I would suggest Microsoft TechNet forums for additional help.

#12

You can try to type troubleshoot (after clicking the Windows button bottom left).

select Troubleshoot that appears on left side of screen.

It should open a troubleshooting Window. Look for Windows Store (somewhere at the bottom). Run the problem fixer. I had it also and store wasn’t working any longer.

Only after that problemsolver, it still wasn’t fixed for me. Try wsreset with admin prompt after running that problem solver. That did it for me. 

Another way is described here https://mspoweruser.com/solution-windows-store-not-working-windows-10/

 

 

 

#13

I would also recommend to open a Admin Shell and type in wsreset

#14

I already did that, wsreset, windows store troubleshoot, try ro reinstall windows store… but nothing changed. The strange thing it’s not working only for games, I can download apps without problem.

#15

And even the powershell command didn’t work that was inside my link? At my office a system administrator turned of games with a policy. Too bad for him I am local admin and could overrule this.

#16

Yes, I try that command before (even the other commands) using both poweshell and cmd, when searching the solution on internet but unfortunately didn’t work. I think I’ll try to update my windows next Saturday. For now, I’m just glad I can play RR2.

#17

Yes, playing the game is most important, but missing 3-4+ chests per day is a lot. It’s the difference between needing to work hard for an important upgrade or not (6-8 unopened video chests generate plenty of gold in several occasions, but also items and other rewards are welcome).

Like I said, it happened to me on december 1 last year that video suddenly were no longer available and I didn’t have videos for about 9 months.  As Windows users we had no videos till February 2016, so when I got them it was a revelation. I for the first time understood the advantage of non Windows players having those videos. While I needed gold shields of a day or longer to collect gold for an expensive upgrade, they just had chests to get remaining gold. 

For me getting no videos any longer was a reason to transfer my account to another device. I got two chests max during weekdays during the period I had no videos working on my main device. But when they also aren’t working it’s hard to compete… Did you also check regional settings and decimal plus thousand separator? (I bet you did)

#18

I don’t know about “decimal plus thousand separator” thing.

By the way what ver windows 10 did you use? I read bugs section about problem in Anniversary Update and Fall Creators Update. Is the problem still there? or already fixed?

#19

I could reproduce the issue with games in the store when using Windows 10 version 1511. I think the store app itself from this old version cannot deal with the current store contents for games. Updating Windows to a current version 1709 will solve this. 

However, I found a workaround. When you search for a game by name, click on the game in the search result preview (below the search box, see screen shot), and it will take you to the game page including the download button:

2017-12-11_18-00-11.png

#20

My build is 10.16299, now a freeze bug occurs in RR2 only, so it’s RR2 related. During the freeze everything else works.

As decimal separator (language or regional settings) you need either a comna or dot sign. As decimal separator the opposite. With a sniffing tool like fiddler you can check the JSON string sended towards Vungle. Check the comment of Thomas

The thousand separator should not be ‘,’ at my machine the decimal separator is comma (’,’) and thousand separator a dot sign. Could that be your problem?