There is no offers. Please try again later

I have 3 android devices and any of them do not show video.

Please share info if you have the same problem.

P.S. On windows device everything is Ok.

I am also facing the same issue… :slightly_frowning_face:  and Its really frustrating when it’s working fine for some and not working at all for others…

Please look into this ASAP… :slight_smile:   

Here the same issue. 2 weeks ago the video-offers did work, now not. I play in the Netherlands, on windows pc.

But that is not so annoying, that everytime I log on, I get an offer for a free chest, which don’t work. So fix it, or don’t offer it.

Haven’t had a freebie chest in over 2 weeks… much lower than the norm…

Alysea told me flare will investigate it. I am also Dutch and play on Windows, no video offers. I don’t know how long I already have no video offers, could be two weeks.

This only increases the disadvantage. I still manage to make the gold plus get the items, but it feels not correct. When there are no Vungle offers for whatever reason(bug or indeed out of videos), why not promote your own games? When I check this forum, there are quite a few other games. 

Hi dena4,in windows PC,you can fix the video offers,as it’s told in the production boost of royal revolt 2 wiki page,it worked for me.

1st close the game,wait for few min,then delete that folder,when you come online again,wait for 2 or 3 min,then watch the video,it’l work for sure.

you said it didn’t work,Try it my way,it might work.

Thank you for trying to help, but it’s not working at my Windows 10 tablet.

I tried that option already a couple of times, even restarted my tablet. I think you are fortunate that it works, I already tried reinstall, wsreset plus that option from production boost.

I did even the following.

  • Start the tablet in the morning (so hours not logged in)
  • Followed the advice of production boost page (Rename the vungle folder)
  • Either
    • Wait for a couple of minutes (not needed, fresh start of tablet, so Vungle isn’t active)
    • or even restart the tablet and wait for a couple of minutes
  • Login to the game and try.
    • New folder is generated by Vungle
    • Still no video offer

Even tried wsreset in elevated command prompts (worked for me a lot of times, but not any more now),

Only option left is reinstalling the game and hope for the best. I will first transfer my account to another tablet (android) somewhere at the end of this week. A friend reinstalled the game and had problems with OneDrive, so the game not automatically restored his account. Since he already transferred his account to his PC, he tried to transfer the account. Last time he retried this transfer scenario he was confronted with transfer limitation, only 2 transfers within 28 days allowed. So constant reinstall is also risky. And I am definitely not going to risk to lose my account for those videos. I am used to raid on that tablet, it will be a disaster if I need to raid on another device or PC.