titan cursed chest don't break

hi support team, please fix the bug. I have titan cursed chest unable to break even though I completed the quest in order to break the curse. When I touch the “Break Curse” button it automatically logout every time I relogin and touch it went off. It’s not from my end but the game app I believe. I have added the screenshot attachment. Thanks.

Yo Thor @knickyiana, try contacting technical support.

https://flaregames.zendesk.com/hc/en-us

@knickyiana This sometimes happens due to the premature completion message appearing while you have not actually fulfilled the requirments . Try doing more tasks the curse required (i.e. capture more ambrosia islands, kill more archers, etc.) and then press the “break” button again. At aome point this should do the trick and you will be able to open the chest.

It happened to me a few times, was advised it was a sever issue, and that it would be able to be unlocked but might take a few hours. Just check back in a few hours :slight_smile:

 

I tried now and then but it never break even though I have completed the task. It must be from game technical error. I tried whole day as I touch the “break curse” button game goes off and I had to reopen the game again and again. Who are the game technician? How may my problem reach the game owner to fix it? I don’t know what to do. Please help somebody. Thank you all

Did you just click on it or actually tried doing more tasks that the chest specified, like I advised above? Tech support is your next stop if nothing works, but they are not working on weekends, as well as the devs. Morgan will see this post some time next week, bur thats about it in terms of help.