touch keyboard keeps popping up after recent update

Hello, It was right after one of your updates, either August 15th or 17th, that the touchscreen keyboard on my laptop keeps popping up after I type a message in the alliance chat or a private message. 

It is infuriatingly annoying because I lost a couple of fights forgetting I had just replied to someone in chat, then immediately started a fight.  When it does this, every single time I touch the screen, the keyboard pops up and you have to hot the “x” to close it.  You can’t fight when it does this.  If I close the game and reopen it, the touchscreen keyboard will be gone. 

Or… if I click on a bonus video.  I’m assuming, anything that breaks away from the game itself for a moment will make the OSK go away. 

If I have that problem, I can also go to the “forums” tab in-game, and when it opens up a new window for the forums here, it “breaks” whatever is making the keyboard pop up and it goes back to normal…until I type something in the chat or pm screens again.  It will make the conquest impossible!  

I have also noticed yesterday that on my computer, if I “swipe” the right side of my screen (bringing up the message center), it also breaks whatever is making the OSK pop up… which is nice because I might be able to make it work with the conquest now, but I really need to have this resolved.  I had never had this happen until the RR2 update on 8/15 or 8/17, sorry I don’t remember which.  It does NOT happen in any other game, program, online or anything else, which is why I believe it’s RR2 related.

Any help would be greatly appreciated. I’m a bit of a technological troglodyte, so I’m not sure if there’s anything on my end that’s wrong.

I’m on an HP ENVY x360 m6 Convertible using Windows 10 Home version 1803.

Thanks in advance, KT4

 

 

nobody else has this issue? only me? ?

 

Hi KT4! Thank you for telling us. We’re gonna have a look into that.

No, you’re not alone. I have exactly the same issue on a Windows 10 version 1803 convertible. Since this issue, I attach the keyboard for typing text, and remove the keyboard for raids. Closing the onscreen keyboard indeed is very tricky. (E.g., when using the small floating keyboard style, you can long tap on the keyboard title to pop up the context menu, and select “Close” there.)

I also have it on Windows and have a temporary fix for you.

This is the trick to remove that keyboard. Close the online keyboard when it becomes visible. Then upper center, start to move the screen downwards, so that the game becomes smaller. Don’t close it! Then let go to make screen big again. 

Voila, away is that screen keyboard.

 

I didn’t try yet, but also this is a possible way.

In Windows 10

Start -> settings -> ease of access -> keyboard.

“on-screen keyboard” switch it to off.  

I didn’t try it yet, since I didn’t know if then my keyboard during login is also disabled or not.

 

Hi Dena4, what version of Windows do you use? I’m on Windows 10 version 1803, and I can’t drag the game window, it will only allow maximized (full screen) or minimized (iconized) state, but not normalized (windowed) state. 

Anyway, the workaround to close the onscreen touch keyboard is to move the input focus to anything else (that takes input) other than RR2. Either the action center (in the case of swipe in from right gesture), the desktop window manager (in your case when moving the window around), or even minimizing RR2 and restoring it again.

Apparently there is now an issue in RR2 telling Windows when text (keyboard) is used or not used.

I use latest version (1803) on my tablet (I work in tablet mode, that might be the reason!).

I think it’s indeed the case that focus must be lost by the game to remove that annoying keyboard popping up all the time.