Unique forge bug

Both uniqe items are equipped. //content.invisioncic.com/Mflaregames/monthly_2018_05/Screenshot_20180525-142548.png.66c2bff41cf51b10acad7a186e1790d4.png  Why does one have a ‘’?’’ 

The result is normal for all other unique items except fire bringer.

Only the fire bringer has a different result.

That unique item has been upgraded to the max for your ascension level. You can curse it, which will put it in a box and transform it into a different unique item, but you can’t do that while it’s equipped.

Thanx dumpster  :slight_smile:

if you like that item, don’t curse it. It doesn’t make it special or anything, it just changes it into a different unique, maybe one you already have.

Hi, I have a similiar issue. I have a 5 star titan item and tried to forge it to a unique item, the game is not recognizing the 5 star item.its saying that i need an item forged to 5 stars still. I just  went up to lvl 111 from 110 and tried to forge it at both levels, it didnt work. I also tried it with other unique items, one that had not ever been forged before without success.

Can you show a screenshot of what’s happening?

Verify that you unequipped the item from all 3 sets of your hero(es).

I did unequip and still not working

this is the unique item

Is it unequipped from the sets 2 and 3 too? If this item is equipped on any set, you can’t use it in forge.

And thats the 5 star titan item, when i attempt to forge the shield it does not find the item. I then tried it on a unique that was never enhanced with the same results

 

Evil smasher is right, you need to go into inventory II and III for Ajax and unequip that 5 Star item

Ooops. I had forgotten to unequipped it from 3rd set. Im a dummy, and thank you