Watching Videos is buggy since 1.42

It was working relatively well until the 1.42 patch. Since then I get often a golden button to watch Videos but when I hit it it hangs arround and then turns into silver?

Is there a specific reason or is there something wrong with it? I found it working much better before the update. Can I roll back my Client?

I don’t know why this is like it is now, but I agree, worked better before…

Also, those videos do give me gems instead of bread, sometimes, now since the update…

I had only 2-3 free food offers as it is region based but after recent update 1.4.2(which is only for android),when I tap on golden button to “watch video” it says “No offers” most of the time,one offer may occures after lot of tries.

 

Yes,so I can confirm both 1.free food offers worked better before.

and also 2.Those videos do give me 1 gem instead of bread,sometimes,now since the update.

As usual it took ages to give us solutions for this problem…take your time as much as you want jona, you have all the time in this world!!!

I’m not saying this is a huge Problem. Just wonder why this has been modified this way…

I can only speculate, but I guess some people might have abused the “unlimited offers” to continue raiding all day long for free, so that change might be a way of capping the number of videos you can consecutively.

 

Also, I didn’t experiment too much with that, but maybe the solution [button still clickable, but will say “no offer available” most of the times] is a try of avoiding a hard cap in order to allow for that one more raid that is necessary for an upgrade, if you try often enough, while still having some kind of limitation (as trying dozens of times for 1 offer would be too inefficient for non-stop-raiding or gem farming etc).

 

For the gem-instead-of-food-reward, I’d say it’s a bug rather than some wanted behaviour here?