Windows 8.1

Will we get the update? 

Ok, big fat silence.  So i’ll add some more…

Frequent players on 8.1 are getting behind because the update is late.  What will Flare do to make up for this?

Since I can’t update, I can’t fight anyone.  Always get the ‘player online’ message.  Is this Flare’s way of asking us to quit the game?

What you need to do is contact the support team if you can’t update the game to 4.0. Here’s the link: https://flaregames.zendesk.com/hc/en-us/requests/new

Hopefully they’ll get back to you and help you out

Whole week and still no update for Windows 8.1. So disappointing. I am emailing support back and forth and all they do is promise it will be fixed at some time while my account is going inactive in the mean time.

Have you tried going to the Windows Store, type in “Royal Revolt 2”, then go to upper right corner for the drop down bar, click on “Settings” then “App Updates” and wait for it to load.  I got the update the day us was released.  I don’t think Flare likes to support Windows 8.1. Since last August, I am still unable to watch videos when I try to boost my farms or taverns or towers. I am also unable to collect free chests and I continue simply get the message “You have no offers at the moment. Please try again later” every time I try. It was suggested that this new Version 4.0 was going to address these issues but it hasn’t.

Mine was four days late, but I got it.  Checked the store every day before logging in.  Never an update.  One day after checking the store I went to the game and it said update available.

 

Contacting support is not helpful.  I could have said that many ways…

It’s fixed now isn’t it? 

Hi, there is no update in my Windows Store. I use Windows 8.1. Does is take more time or where is the problem?

The problem must be with the store itself, many 8.1 users have zero updates available in the store, not only rr2 update, there are no updates at all. 

i believe 8.1 is no longer supported 

No, it is not fixed at all. I have 3 computers with Windows 8.1 at work and none have 4.0 updated version in store. All show 3.9 only. Just pathetic.

No it’s not. Flare is doing it’s usual Screw You Win8.1 players,

 

And your link to notify them?

https://flaregames.zendesk.com/hc/en-us/requests/new

Times out. Times out. Times out. Times out.

 

ETA: Request for help sent Aug 9th. Let’s see if that does ANYTHING.

@Madlen, can you help us out here. Is it just a problem with the Windows 8.1 Store or is a problem with RR2

Are you sure Windows 8.1 still supported? I have read somewhere in a another topic there is no more update for 8.1 because no more supported. Maybe the rumor is wrong too I don’t know. Guys time to follow the technologies and left behind what must stay behind. Windows XP,Windows 7 was cool and some who still use 8.1 but a moment you must advance in the life and accept the technologies evolve. Its hard for the heart but its for the better. Windows 10 Pro. Or get on the internet Windows 10 Home. You can the iso and install it

Flare said last update they would not keep updating 8.1 

I think that was not long after ninja.

Got a reply from Flare telling me I should empty out my Windows Store cache but they didn’t know how to do it.

It took me less than 45 seconds on google to find out how.

That is the level of tech support and customer service on here.

Game still unable to be updated.

 

Apart from not having RR2 update, do you guys also have  general problem with windows store like me ? When I try to go to my apps there is an error, cannot have a look at them. When I try to manually search for new updates it shows me that no updates are available, zero. Usually there’s a ton. I keep thinking that there must be an issue with the store itself, not RR2. Also I think I heard of someone updating it on one acc but not being able to do so on the other. Anyway, I tried clearing store cache and other tricks I googled but nothing worked, still not seeing any updates of any apps I own.  When I went to RR2 in store it showed me 3.9 update as last. When I unistalled RR2 completely I went to store, hit ‘install’ button and got some kind of ‘purchase error’ that was saying my device doesn’t meet requirements, though I think it does. Not sure.

Hi guys,

We are sorry some of you cannot update to the new version. However, the problem seems to be on Microsoft’s side. We have contacted them and are waiting for a reply. Once I know more, I will let you know.

So we missed the conquest, pro league and time for upgrades.Can we expect at least some kind of compensation when this will be resolved?

I had the game previously installed on Win 8.1 some time ago, and it worked fine. Uninstalled and tried to re-install yesterday. Now I can’t install it any more, because when I try I get an error message in the Windows store saying (in German; translation may not be verbatim): “Your PC might not meet some of the requirements …”