Zelos ring is bugged since the last update

#1

Ring of Zelos has been bugged for me since the last update. Since Flare changed the way range is displayed from 60% to 3,0. The range actually seems to have become 60:3=20x less.

Tried unequipping the ring on all gear sets and playing a match without it, didnt work.Tried it again and restarting game, didnt work. Tried reinstalling the game, didnt work.

I know there are more people having this problem and I kindly ask @PaSte and @FTB or anyone else from Flare to give us ANY info about this bug. Just confirming it is indeed bugged would be enough.

I will keep on trying to find some way to fix this. If any information is needed I will provide it.

#2

and again … on the laptop version of the game 3.8.0. and the ring has 60%, and it works well. on android 3.8.1, and the ring is 3.0, and it does not work!

#3

Ring seems to have been fixed since the last maintenance break.

Funny enough it went down from 3,0 to 2,83 and I can forge it again with 0,01 increments.

Anyway thanks Flare for fixing it but you guys seriously need to work on communication.

#4

I confirm! I check for version 3.8.2. all fixed